diff configure.in @ 3199:3e1bf2b8bd81

This check in updates SDL_atomic.h to reflect the new set of atomic operations in 32 and 64 bit form. It also update configure.in to compile the linux version of the library. The three versions are all dummies implementations that do nothing. They are being checked in as place holders. Mostly, I just wanted to get place holders and the configure.in checked in.
author Bob Pendleton <bob@pendleton.com>
date Wed, 24 Jun 2009 20:04:08 +0000
parents 77d6336711fc
children 5625ba0a1e25
line wrap: on
line diff
--- a/configure.in	Wed Jun 17 04:26:19 2009 +0000
+++ b/configure.in	Wed Jun 24 20:04:08 2009 +0000
@@ -217,6 +217,12 @@
 
 dnl Enable/disable various subsystems of the SDL library
 
+AC_ARG_ENABLE(atomic,
+AC_HELP_STRING([--enable-atomic], [Enable the atomic operations subsystem [[default=yes]]]),
+              , enable_atomic=yes)
+if test x$enable_atomic != xyes; then
+    AC_DEFINE(SDL_ATOMIC_DISABLED)
+fi
 AC_ARG_ENABLE(audio,
 AC_HELP_STRING([--enable-audio], [Enable the audio subsystem [[default=yes]]]),
               , enable_audio=yes)
@@ -2433,6 +2439,16 @@
             ;;
           esac
         fi
+        # Set up files for the atomic operations library
+        if test x$enable_atomic = xyes; then
+          case $ARCH in
+            linux)
+                AC_DEFINE(SDL_ATOMIC_LINUX)
+                SOURCES="$SOURCES $srcdir/src/atomic/linux/*.c"
+                have_atomic=yes
+            ;;
+          esac
+        fi
         # Set up files for the joystick library
         if test x$enable_joystick = xyes; then
           case $ARCH in