diff configure.in @ 3901:3a7248359cdd SDL-1.2

Merge r2921:2922 from SDL trunk to 1.2 branch: mingw alloca.h workaround.
author Ryan C. Gordon <icculus@icculus.org>
date Fri, 01 Dec 2006 20:26:06 +0000
parents 636320238bc8
children 8a3a0f1179f3
line wrap: on
line diff
--- a/configure.in	Wed Nov 29 10:30:05 2006 +0000
+++ b/configure.in	Fri Dec 01 20:26:06 2006 +0000
@@ -124,7 +124,14 @@
     fi
 
     dnl Checks for library functions.
-    AC_FUNC_ALLOCA
+    case "$host" in
+    *-*-cygwin* | *-*-mingw32*)
+        ;;
+    *)
+        AC_FUNC_ALLOCA
+        ;;
+    esac
+
     AC_FUNC_MEMCMP
     if test x$ac_cv_func_memcmp_working = xyes; then
         AC_DEFINE(HAVE_MEMCMP)