diff configure.in @ 166:39877400bd1e

Fixed Solaris nitpicks (thanks Mattias!)
author Sam Lantinga <slouken@libsdl.org>
date Tue, 04 Sep 2001 22:48:09 +0000
parents 4382c38dfbee
children cb384ef627f6
line wrap: on
line diff
--- a/configure.in	Tue Sep 04 22:38:01 2001 +0000
+++ b/configure.in	Tue Sep 04 22:48:09 2001 +0000
@@ -1196,20 +1196,14 @@
     # and what runs on older Macs - while in theory "Carbon" defns
     # are consistent between the two, in practice Carbon is still
     # changing. -sts Aug 2000
+    mac_autoconf_target_workaround="MAC"
     CFLAGS="$CFLAGS -I/System/Library/Frameworks/Carbon.framework/Headers \
       -I/System/Library/Frameworks/Cocoa.framework/Headers -fpascal-strings \
-      -DENABLE_QUARTZ -DMACOSX -DTARGET_API_MAC_CARBON=1 -I\$(top_srcdir)/src/video/quartz"
+      -DENABLE_QUARTZ -DMACOSX -DTARGET_API_${mac_autoconf_target_workaround}_CARBON=1 -I\$(top_srcdir)/src/video/quartz"
     VIDEO_SUBDIRS="$VIDEO_SUBDIRS quartz"
     VIDEO_DRIVERS="$VIDEO_DRIVERS quartz/libvideo_quartz.la"
 }
 
-dnl Set up the kernel statistics library for Solaris
-CheckKSTAT()
-{
-    CFLAGS="$CFLAGS -DHAVE_KSTAT"
-    SYSTEM_LIBS="$SYSTEM_LIBS -lkstat"
-}
-
 case "$target" in
     *-*-linux*)
         ARCH=linux
@@ -1516,7 +1510,6 @@
         CheckAAlib
         CheckOpenGL
         CheckPTHREAD
-        CheckKSTAT
         # Set up files for the main() stub
         COPY_ARCH_SRC(src/main, linux, SDL_main.c)
         # Set up files for the audio library
@@ -1566,7 +1559,6 @@
         CheckAAlib
         CheckOpenGL
         CheckPTHREAD
-        CheckKSTAT
         # Set up files for the main() stub
         COPY_ARCH_SRC(src/main, linux, SDL_main.c)
         # Set up files for the audio library