diff configure.in @ 1697:393092a3ebf6 SDL-1.3

Fixed bug #157 [patch tweaked to handle older nasm, which doesn't support :function syntax] ------- Comment #5 From Mike Frysinger 2006-05-22 01:24 [reply] ------- Created an attachment (id=132) [edit] libsdl-hidden-nasm.patch here's the patch i posted here: http://www.libsdl.org/pipermail/sdl/2006-March/073618.html this will hide the symbols dynamically if the build nasm/yasm supports the hidden stuff ... in other words, this patch should be safe with both older and new versions of nasm/yasm
author Sam Lantinga <slouken@libsdl.org>
date Wed, 21 Jun 2006 07:57:59 +0000
parents 75f2ace8511a
children 21184e1d04c3
line wrap: on
line diff
--- a/configure.in	Wed Jun 21 07:36:00 2006 +0000
+++ b/configure.in	Wed Jun 21 07:57:59 2006 +0000
@@ -596,11 +596,14 @@
 AC_HELP_STRING([--enable-nasm], [use nasm assembly blitters on x86 [[default=yes]]]),
                   , enable_nasm=yes)
     if test x$enable_video = xyes -a x$enable_assembly = xyes -a x$enable_nasm = xyes; then
-        AC_PATH_PROG(NASM, nasm)
-        if test x$NASM != x -a x$NASM != x'"$NASM"'; then
+        AC_PATH_PROG(NASM, yasm)
+        if test "x$NASM" = x -o "x$NASM" = x'"$NASM"'; then
+            AC_PATH_PROG(NASM, nasm)
+        fi
+        if test "x$NASM" != x -a "x$NASM" != x'"$NASM"'; then
             AC_DEFINE(SDL_HERMES_BLITTERS)
             SOURCES="$SOURCES $srcdir/src/hermes/*.asm"
-            if test x$NASMFLAGS = x; then
+            if test x"$NASMFLAGS" = x; then
                 case $ARCH in
                   win32)
                       NASMFLAGS="-f win32"
@@ -613,6 +616,15 @@
                       ;;
                 esac
             fi
+            NASMFLAGS="$NASMFLAGS -i $srcdir/src/hermes/"
+
+            dnl See if hidden visibility is supported
+            echo 'GLOBAL _bar:function hidden' > nasm_vis.asm
+            if $NASM $NASMFLAGS nasm_vis.asm -o nasm_vis.o >&AS_MESSAGE_LOG_FD ; then
+                NASMFLAGS="$NASMFLAGS -DHIDDEN_VISIBILITY"
+            fi
+            rm -f nasm_vis.asm nasm_vis.o
+
             AC_SUBST(NASM)
             AC_SUBST(NASMFLAGS)