diff test/configure.in @ 1550:31c2b8e4885e

Fixed bug #166 From the autoconf obsolete macros documentation: Macro: AC_CANONICAL_SYSTEM Determine the system type and set output variables to the names of the canonical system types. See section Getting the Canonical System Type, for details about the variables this macro sets. The user is encouraged to use either AC_CANONICAL_BUILD, or AC_CANONICAL_HOST, or AC_CANONICAL_TARGET, depending on the needs. Using AC_CANONICAL_TARGET is enough to run the two other macros. From the documentation for the canonical environments: case $target in i386-*-mach* | i386-*-gnu*) obj_format=aout emulation=mach bfd_gas=yes ;; i960-*-bout) obj_format=bout ;; esac Note that the above example uses $target because it's taken from a tool which can be built on some architecture ($build), run on another ($host), but yet handle data for a third architecture ($target). Such tools are usually part of a compiler suite, they generate code for a specific $target. However $target should be meaningless for most packages. If you want to base a decision on the system where your program will be run, make sure you use the $host variable.
author Sam Lantinga <slouken@libsdl.org>
date Sun, 19 Mar 2006 05:27:22 +0000
parents 835c1831f903
children 0a53c90a37f9 a7cda692b681
line wrap: on
line diff
--- a/test/configure.in	Sat Mar 18 22:42:09 2006 +0000
+++ b/test/configure.in	Sun Mar 19 05:27:22 2006 +0000
@@ -1,9 +1,9 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_INIT(README)
 
-dnl Detect the canonical host and target build environment
+dnl Detect the canonical build and host environments
 AC_CONFIG_AUX_DIRS($srcdir/../build-scripts)
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_HOST
 
 dnl Check for tools
 
@@ -14,7 +14,7 @@
 AC_C_CONST
 
 dnl Figure out which math library to use
-case "$target" in
+case "$host" in
     *-*-cygwin* | *-*-mingw32*)
         EXE=".exe"
         MATHLIB=""