diff configure.in @ 1945:3182150b470f

PicoGUI is no longer maintained by the author.
author Sam Lantinga <slouken@libsdl.org>
date Wed, 26 Jul 2006 03:55:56 +0000
parents 91f41fc124a7
children 420716272158
line wrap: on
line diff
--- a/configure.in	Wed Jul 26 03:24:27 2006 +0000
+++ b/configure.in	Wed Jul 26 03:55:56 2006 +0000
@@ -1302,31 +1302,6 @@
     fi
 }
 
-dnl Set up the PicoGUI video driver if enabled
-CheckPicoGUI()
-{
-    AC_ARG_ENABLE(video-picogui,
-AC_HELP_STRING([--enable-video-picogui], [use PicoGUI video driver [[default=no]]]),
-                  , enable_video_picogui=no)
-    if test x$enable_video = xyes -a x$enable_video_picogui = xyes; then
-        AC_MSG_CHECKING(for PicoGUI support)
-        video_picogui=no
-        AC_TRY_COMPILE([
-         #include <picogui.h>
-        ],[
-        ],[
-        video_picogui=yes
-        ])
-        AC_MSG_RESULT($video_picogui)
-        if test x$video_picogui = xyes; then
-            AC_DEFINE(SDL_VIDEO_DRIVER_PICOGUI)
-            SOURCES="$SOURCES $srcdir/src/video/picogui/*.c"
-            SDL_LIBS="$SDL_LIBS -lpgui"
-            have_video=yes
-        fi
-    fi
-}
-
 dnl Set up the Atari Bios keyboard driver
 CheckAtariBiosEvent()
 {
@@ -2063,7 +2038,6 @@
         CheckVGL
         CheckWscons
         CheckQtopia
-        CheckPicoGUI
         CheckOpenGLX11
         CheckInputEvents
         CheckTslib