diff configure.in @ 153:2839f45bdba0

Fixed IDE and SCSI CD-ROM detection on BeOS (thanks Caz!)
author Sam Lantinga <slouken@libsdl.org>
date Sat, 18 Aug 2001 22:03:11 +0000
parents 8758b8d42cd9
children 4382c38dfbee
line wrap: on
line diff
--- a/configure.in	Sat Aug 18 21:58:26 2001 +0000
+++ b/configure.in	Sat Aug 18 22:03:11 2001 +0000
@@ -1237,7 +1237,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, linux, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS linux"
+            CDROM_DRIVERS="$CDROM_DRIVERS linux/libcdrom_linux.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1302,7 +1303,8 @@
         # Set up files for the cdrom library
         # (No cdrom support yet)
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, dummy, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1353,7 +1355,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, freebsd, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS freebsd"
+            CDROM_DRIVERS="$CDROM_DRIVERS freebsd/libcdrom_freebsd.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1404,7 +1407,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, openbsd, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS openbsd"
+            CDROM_DRIVERS="$CDROM_DRIVERS openbsd/libcdrom_openbsd.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1463,7 +1467,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, openbsd, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS openbsd"
+            CDROM_DRIVERS="$CDROM_DRIVERS openbsd/libcdrom_openbsd.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1517,7 +1522,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, dummy, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1566,7 +1572,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, linux, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS linux"
+            CDROM_DRIVERS="$CDROM_DRIVERS linux/libcdrom_linux.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1612,7 +1619,8 @@
         # Set up files for the cdrom library
         # (No CD-ROM support yet)
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, dummy, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1673,7 +1681,8 @@
         # Set up files for the cdrom library
         # (No CD-ROM support yet)
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, dummy, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1717,7 +1726,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, aix, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS aix"
+            CDROM_DRIVERS="$CDROM_DRIVERS aix/libcdrom_aix.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1762,7 +1772,8 @@
         # Set up files for the cdrom library
         # (No cdrom support yet)
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, dummy, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1806,7 +1817,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, qnx, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS qnx"
+            CDROM_DRIVERS="$CDROM_DRIVERS qnx/libcdrom_qnx.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1858,7 +1870,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, win32, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS win32"
+            CDROM_DRIVERS="$CDROM_DRIVERS win32/libcdrom_win32.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1913,7 +1926,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, beos, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS beos"
+            CDROM_DRIVERS="$CDROM_DRIVERS beos/libcdrom_beos.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -1956,7 +1970,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, macos, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS macos"
+            CDROM_DRIVERS="$CDROM_DRIVERS macos/libcdrom_macos.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -2002,7 +2017,8 @@
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
-            COPY_ARCH_SRC(src/cdrom, dummy, SDL_syscdrom.c)
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
         fi
         # Set up files for the thread library
         if test x$enable_threads = xyes; then
@@ -2077,6 +2093,8 @@
 AC_SUBST(VIDEO_DRIVERS)
 AC_SUBST(JOYSTICK_SUBDIRS)
 AC_SUBST(JOYSTICK_DRIVERS)
+AC_SUBST(CDROM_SUBDIRS)
+AC_SUBST(CDROM_DRIVERS)
 AC_SUBST(SDL_EXTRADIRS)
 AC_SUBST(SDL_EXTRALIBS)
 AC_SUBST(SYSTEM_LIBS)
@@ -2164,6 +2182,15 @@
 src/joystick/macos/Makefile
 src/joystick/win32/Makefile
 src/cdrom/Makefile
+src/cdrom/aix/Makefile
+src/cdrom/beos/Makefile
+src/cdrom/dummy/Makefile
+src/cdrom/freebsd/Makefile
+src/cdrom/linux/Makefile
+src/cdrom/macos/Makefile
+src/cdrom/openbsd/Makefile
+src/cdrom/qnx/Makefile
+src/cdrom/win32/Makefile
 src/thread/Makefile
 src/timer/Makefile
 src/endian/Makefile