diff configure.in @ 1661:281d3f4870e5 SDL-1.3

Moved DirectInput joystick code to 1.3 branch
author Sam Lantinga <slouken@libsdl.org>
date Sun, 21 May 2006 17:27:13 +0000
parents 14717b52abc0
children 75f2ace8511a
line wrap: on
line diff
--- a/configure.in	Sat May 20 04:35:58 2006 +0000
+++ b/configure.in	Sun May 21 17:27:13 2006 +0000
@@ -2287,8 +2287,13 @@
         fi
         # Set up files for the joystick library
         if test x$enable_joystick = xyes; then
-            AC_DEFINE(SDL_JOYSTICK_WINMM)
-            SOURCES="$SOURCES $srcdir/src/joystick/win32/*.c"
+            if test x$have_directx = xyes; then
+                AC_DEFINE(SDL_JOYSTICK_DINPUT)
+                SOURCES="$SOURCES $srcdir/src/joystick/win32/SDL_dxjoystick.c"
+            else
+                AC_DEFINE(SDL_JOYSTICK_WINMM)
+                SOURCES="$SOURCES $srcdir/src/joystick/win32/SDL_mmjoystick.c"
+            fi
             have_joystick=yes
         fi
         # Set up files for the cdrom library