diff configure.in @ 2810:27cb878a278e

Implemented the X11 (non-OpenGL) renderer, no alpha or scaling available.
author Sam Lantinga <slouken@libsdl.org>
date Sun, 30 Nov 2008 21:58:23 +0000
parents b14f672b2857
children 33ddad305f3d
line wrap: on
line diff
--- a/configure.in	Sat Nov 29 21:48:14 2008 +0000
+++ b/configure.in	Sun Nov 30 21:58:23 2008 +0000
@@ -1172,6 +1172,13 @@
                     AC_DEFINE(SDL_VIDEO_DRIVER_X11_DPMS)
                 fi
             fi
+
+            AC_ARG_ENABLE(render-x11,
+AC_HELP_STRING([--enable-render-x11], [enable the X11 render driver [[default=yes]]]),
+                                , enable_render_x11=yes)
+            if test x$enable_render_x11 = xyes; then
+                AC_DEFINE(SDL_VIDEO_RENDER_X11)
+            fi
         fi
     fi
 }