diff configure.in @ 471:26dafefeebb2

Date: Sat, 24 Aug 2002 22:20:01 -0600 From: "Greg Haerr" Subject: Announce: sdl-nanox-patch Sam, I've created an update patch for enhanced Nano-X support with SDL. I've created the patch against SDL-1.2.4. I'd appreciate it if you would apply it to the next SDL version. Enhancements include: 1. Small bugfixes to compile without errors 2. Support for direct client-side framebuffer access with configure option 3. Add dynamic pixel type support for hardware framebuffer; eliminating the need for compile-time configuration option. I've updated the README.NanoX file with the details. This version has been tested with Microwindows v0.89pre9 CVS and SMPEG 0.4.4. I've added multi-threading support to Microwindows to support the multi-threaded SMPEG, and all works fine. To turn on thread safety in Microwindows, use THREADSAFE=Y in the Microwindows config file. Thanks! Regards, Greg Founder, The Microwindows Project http://microwindows.org
author Sam Lantinga <slouken@libsdl.org>
date Sun, 25 Aug 2002 06:21:49 +0000
parents 3691cc3e14b3
children 22581630aab7
line wrap: on
line diff
--- a/configure.in	Sun Aug 25 02:05:24 2002 +0000
+++ b/configure.in	Sun Aug 25 06:21:49 2002 +0000
@@ -511,9 +511,9 @@
     AC_ARG_ENABLE(nanox-share-memory,  
         [  --enable-nanox-share-memory use share memory [default=no]],
         , enable_nanox_share_memory=no)
-
-    AC_ARG_WITH(nanox_pixel_type, 
-        [  --with-nanox-pixel-type=[rgb/0888/888/565/555/332/pal]])
+    AC_ARG_ENABLE(nanox_direct_fb, 
+        [  --enable-nanox-direct-fb use direct framebuffer access [default=no]],
+        , enable_nanox_direct_fb=no)
 
     if test x$enable_video = xyes -a x$enable_video_nanox = xyes; then
         if test x$enable_nanox_debug = xyes; then
@@ -524,16 +524,9 @@
             CFLAGS="$CFLAGS -DNANOX_SHARE_MEMORY"
         fi
 
-        case "$with_nanox_pixel_type" in
-             rgb) CFLAGS="$CFLAGS -DNANOX_PIXEL_RGB" ;;
-            0888) CFLAGS="$CFLAGS -DNANOX_PIXEL_0888" ;;
-             888) CFLAGS="$CFLAGS -DNANOX_PIXEL_888"  ;;
-             565) CFLAGS="$CFLAGS -DNANOX_PIXEL_565"  ;;
-             555) CFLAGS="$CFLAGS -DNANOX_PIXEL_555"  ;;
-             332) CFLAGS="$CFLAGS -DNANOX_PIXEL_332"  ;;
-             pal) CFLAGS="$CFLAGS -DNANOX_PIXEL_PAL"  ;;
-               *) AC_MSG_ERROR([Invalid nanox_pixel_type]);;
-        esac
+        if test x$enable_nanox_direct_fb = xyes; then
+            CFLAGS="$CFLAGS -DENABLE_NANOX_DIRECT_FB"
+        fi
 
         CFLAGS="$CFLAGS $X_CFLAGS -DENABLE_NANOX"
         SYSTEM_LIBS="$SYSTEM_LIBS -lnano-X"