diff configure.in @ 3217:26ce0b98f2fb

Support for native and emulated atomic operations has been added.
author Mike Gorchak <lestat@i.com.ua>
date Sun, 19 Jul 2009 08:04:59 +0000
parents 5625ba0a1e25
children af4a5af3cd2b
line wrap: on
line diff
--- a/configure.in	Thu Jul 09 21:31:27 2009 +0000
+++ b/configure.in	Sun Jul 19 08:04:59 2009 +0000
@@ -2572,6 +2572,12 @@
             SOURCES="$SOURCES $srcdir/src/timer/unix/*.c"
             have_timers=yes
         fi
+        # Setup files for the atomic operations
+        if test x$enable_atomic = xyes; then
+                AC_DEFINE(SDL_ATOMIC_QNX)
+                SOURCES="$SOURCES $srcdir/src/atomic/qnx/*.c"
+                have_atomic=yes
+        fi
         # Set up dummy files for the joystick for now
         if test x$enable_joystick = xyes; then
             AC_DEFINE(SDL_JOYSTICK_DUMMY)