diff configure.in @ 227:24878c14b391

Added X11 Xinerama support - fullscreen starts on screen 0
author Sam Lantinga <slouken@libsdl.org>
date Sat, 03 Nov 2001 17:03:16 +0000
parents 0a98dba2c700
children b6084de9431a
line wrap: on
line diff
--- a/configure.in	Fri Nov 02 22:41:32 2001 +0000
+++ b/configure.in	Sat Nov 03 17:03:16 2001 +0000
@@ -602,6 +602,26 @@
                     SYSTEM_LIBS="$SYSTEM_LIBS -lXv"
                 fi
             fi
+            AC_ARG_ENABLE(video-x11-xinerama,
+[  --enable-video-x11-xinerama   enable X11 Xinerama support [default=yes]],
+                            , enable_video_x11_xinerama=yes)
+            if test x$enable_video_x11_xinerama = xyes; then
+                AC_MSG_CHECKING(for X11 Xinerama support)
+                video_x11_xinerama=no
+                AC_TRY_COMPILE([
+                 #include <X11/Xlib.h>
+                 #include <X11/extensions/Xinerama.h>
+                ],[
+                 XineramaScreenInfo *xinerama;
+                ],[
+                video_x11_xinerama=yes
+                ])
+                AC_MSG_RESULT($video_x11_xinerama)
+                if test x$video_x11_xinerama = xyes; then
+                    CFLAGS="$CFLAGS -DHAVE_XINERAMA"
+                    SYSTEM_LIBS="$SYSTEM_LIBS -lXinerama"
+                fi
+            fi
         fi
     fi
 }