diff configure.in @ 1854:2280e314a978

Closed bug #74 Added DirectInput joystick code, contributed by Glenn Maynard. This fixes a problem with the Windows Multimedia joystick driver not showing all 6 axes on a GameCube controller converter, which was donated by Jacob Kolding.
author Sam Lantinga <slouken@libsdl.org>
date Sun, 21 May 2006 16:47:41 +0000
parents 703f7268b5b1
children 5ff2c01e475e
line wrap: on
line diff
--- a/configure.in	Sun May 21 02:50:05 2006 +0000
+++ b/configure.in	Sun May 21 16:47:41 2006 +0000
@@ -2270,8 +2270,13 @@
         fi
         # Set up files for the joystick library
         if test x$enable_joystick = xyes; then
-            AC_DEFINE(SDL_JOYSTICK_WINMM)
-            SOURCES="$SOURCES $srcdir/src/joystick/win32/*.c"
+            if test x$have_directx = xyes; then
+                AC_DEFINE(SDL_JOYSTICK_DINPUT)
+                SOURCES="$SOURCES $srcdir/src/joystick/win32/SDL_dxjoystick.c"
+            else
+                AC_DEFINE(SDL_JOYSTICK_WINMM)
+                SOURCES="$SOURCES $srcdir/src/joystick/win32/SDL_mmjoystick.c"
+            fi
             have_joystick=yes
         fi
         # Set up files for the cdrom library