diff configure.in @ 178:1fc1a101bf23

Added CD-ROM support for BSD/OS (thanks Steven!)
author Sam Lantinga <slouken@libsdl.org>
date Thu, 13 Sep 2001 15:57:48 +0000
parents da9a97f693a8
children 34d316d5e744
line wrap: on
line diff
--- a/configure.in	Wed Sep 12 05:11:15 2001 +0000
+++ b/configure.in	Thu Sep 13 15:57:48 2001 +0000
@@ -1347,18 +1347,18 @@
             JOYSTICK_DRIVERS="$JOYSTICK_DRIVERS dummy/libjoystick_dummy.la"
         fi
         # Set up files for the cdrom library
-        # (No cdrom support yet)
         if test x$enable_cdrom = xyes; then
-            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
-            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
+            CDROM_SUBDIRS="$CDROM_SUBDIRS bsdi"
+            CDROM_DRIVERS="$CDROM_DRIVERS bsdi/libcdrom_bsdi.la"
         fi
         # Set up files for the thread library
+        SDL_LIBS="$SDL_LIBS -lsem"
         if test x$enable_threads = xyes; then
             COPY_ARCH_SRC(src/thread, linux, SDL_systhread.c)
             COPY_ARCH_SRC(src/thread, linux, SDL_systhread_c.h)
             COPY_ARCH_SRC(src/thread, linux, SDL_sysmutex.c)
             COPY_ARCH_SRC(src/thread, linux, SDL_sysmutex_c.h)
-            COPY_ARCH_SRC(src/thread, generic, SDL_syssem.c)
+            COPY_ARCH_SRC(src/thread, linux, SDL_syssem.c)
             COPY_ARCH_SRC(src/thread, generic, SDL_syssem_c.h)
             COPY_ARCH_SRC(src/thread, linux, SDL_syscond.c)
             COPY_ARCH_SRC(src/thread, generic, SDL_syscond_c.h)
@@ -2247,6 +2247,7 @@
 src/cdrom/aix/Makefile
 src/cdrom/beos/Makefile
 src/cdrom/dummy/Makefile
+src/cdrom/bsdi/Makefile
 src/cdrom/freebsd/Makefile
 src/cdrom/linux/Makefile
 src/cdrom/macos/Makefile