diff configure.in @ 5045:1cee937d9fcc

Nobody has stepped up to maintain a framebuffer console driver. Bye bye! :)
author Sam Lantinga <slouken@libsdl.org>
date Wed, 19 Jan 2011 22:18:45 -0800
parents 3ce345cc46f8
children edaf3e364a05
line wrap: on
line diff
--- a/configure.in	Wed Jan 19 19:51:04 2011 -0800
+++ b/configure.in	Wed Jan 19 22:18:45 2011 -0800
@@ -1420,33 +1420,6 @@
     fi
 }
 
-dnl Find the framebuffer console includes
-CheckFBCON()
-{
-    AC_ARG_ENABLE(video-fbcon,
-AC_HELP_STRING([--enable-video-fbcon], [use framebuffer console video driver [[default=no]]]),
-                  , enable_video_fbcon=no)
-    if test x$enable_video = xyes -a x$enable_video_fbcon = xyes; then
-        AC_MSG_CHECKING(for framebuffer console support)
-        video_fbcon=no
-        AC_TRY_COMPILE([
-         #include <linux/fb.h>
-         #include <linux/kd.h>
-         #include <linux/keyboard.h>
-        ],[
-        ],[
-        video_fbcon=yes
-        ])
-        AC_MSG_RESULT($video_fbcon)
-        if test x$video_fbcon = xyes; then
-            AC_CHECK_FUNCS(getpagesize)
-            AC_DEFINE(SDL_VIDEO_DRIVER_FBCON)
-            SOURCES="$SOURCES $srcdir/src/video/fbcon/*.c"
-            have_video=yes
-        fi
-    fi
-}
-
 dnl Find DirectFB
 CheckDirectFB()
 {
@@ -2300,7 +2273,6 @@
         CheckESD
         CheckNAS
         CheckX11
-        CheckFBCON
         CheckDirectFB
         CheckFusionSound
         CheckPS3