diff configure.in @ 1187:19d8949b4584

To: sdl@libsdl.org From: Staffan Ulfberg <staffan@ulfberg.se> Date: 19 Nov 2005 01:00:48 +0100 Subject: [SDL] New driver for OpenBSD/wscons Hello, I've written an SDL driver for OpenBSD/wscons (console mode, somewhat resembling the functionality of the svga driver for Linux). I use it for playing MAME on my Sharp Zaurus. The alternative is to play under X, which is slower. I asked how to submit the driver a few days ago, and posted a link to the patch in a follow-up, so maybe it was missed? Anyway, the patch is on the web at: http://multivac.fatburen.org/SDL-wscons.patch Comments? Staffan
author Ryan C. Gordon <icculus@icculus.org>
date Tue, 22 Nov 2005 15:19:50 +0000
parents 867f521591e5
children 2bd4cec0de63
line wrap: on
line diff
--- a/configure.in	Tue Nov 22 15:11:33 2005 +0000
+++ b/configure.in	Tue Nov 22 15:19:50 2005 +0000
@@ -1645,6 +1645,37 @@
     fi
 }
 
+dnl Set up the wscons video driver if enabled
+CheckWscons()
+{
+    AC_ARG_ENABLE(video-wscons,
+[  --enable-video-wscons   use wscons video driver [default=no]],
+                  , enable_video_wscons=no)
+    if test x$enable_video = xyes -a x$enable_video_wscons = xyes; then
+        AC_MSG_CHECKING(for wscons support)
+        video_wscons=no
+        AC_LANG_C
+        AC_TRY_COMPILE([
+       #include <sys/time.h>
+       #include <dev/wscons/wsconsio.h>
+        ],[
+        ],[
+        video_wscons=yes
+        ])
+        AC_MSG_RESULT($video_wscons)
+        if test x$video_wscons = xyes; then
+            CFLAGS="$CFLAGS -DENABLE_WSCONS"
+            VIDEO_SUBDIRS="$VIDEO_SUBDIRS wscons"
+            VIDEO_DRIVERS="$VIDEO_DRIVERS wscons/libvideo_wscons.la"
+        else
+      AC_MSG_ERROR([
+*** Failed to find wscons includes.])
+        fi
+      AC_LANG_C
+    fi
+}
+
+
 dnl Set up the PicoGUI video driver if enabled
 CheckPicoGUI()
 {
@@ -2210,6 +2241,7 @@
         CheckNAS
         CheckX11
         CheckAAlib
+	CheckWscons
         CheckOpenGL
         CheckPTHREAD
         CheckSIGACTION
@@ -3088,6 +3120,7 @@
 src/video/picogui/Makefile
 src/video/ps2gs/Makefile
 src/video/qtopia/Makefile
+src/video/wscons/Makefile
 src/video/quartz/Makefile
 src/video/riscos/Makefile
 src/video/svga/Makefile