diff configure.in @ 5048:187d7d446306

PS3 Linux is no more...
author Sam Lantinga <slouken@libsdl.org>
date Wed, 19 Jan 2011 22:25:40 -0800
parents edaf3e364a05
children 2add0d17180b
line wrap: on
line diff
--- a/configure.in	Wed Jan 19 22:21:31 2011 -0800
+++ b/configure.in	Wed Jan 19 22:25:40 2011 -0800
@@ -1546,46 +1546,6 @@
     fi
 }
 
-dnl See if we're running on PlayStation 3 Cell hardware
-CheckPS3()
-{
-  AC_ARG_ENABLE(video-ps3,
-                AC_HELP_STRING([--enable-video-ps3], [use PlayStation 3 Cell driver [[default=yes]]]),
-                , enable_video_ps3=yes)
-  if test x$enable_video = xyes -a x$enable_video_ps3 = xyes; then 
-    video_ps3=no
-    AC_CHECK_HEADER([linux/fb.h])
-    AC_CHECK_HEADER([asm/ps3fb.h], [have_ps3fb_hdr=yes], [],
-            [#ifndef _LINUX_TYPES_H
-                #include <linux/types.h>
-            #endif])
-    AC_CHECK_HEADER([libspe2.h], have_libspe2_hdr=yes)
-    AC_CHECK_LIB([spe2], spe_context_create, have_spe2_lib=yes)
-
-    AC_CHECK_PROGS(SPU_GCC, [spu-gcc])
-    AC_CHECK_PROGS(EMBEDSPU, [embedspu])
-
-    have_spu_libs=yes
-    AC_CHECK_LIB([fb_writer_spu], [main], [], [have_spu_libs=no])
-    AC_CHECK_LIB([yuv2rgb_spu], [main], [], [have_spu_libs=no])
-    AC_CHECK_LIB([bilin_scaler_spu], [main], [], [have_spu_libs=no])
-    if test x$have_ps3fb_hdr = xyes -a x$have_libspe2_hdr = xyes -a x$have_spe2_lib = xyes -a "$SPU_GCC" -a "$EMBEDSPU"; then
-        AC_DEFINE(SDL_VIDEO_DRIVER_PS3)
-        video_ps3=yes
-        have_video=yes
-        SOURCES="$SOURCES $srcdir/src/video/ps3/*.c"
-        EXTRA_CFLAGS="$EXTRA_CFLAGS -I/opt/cell/sdk/usr/include"
-        EXTRA_LDFLAGS="$EXTRA_LDFLAGS -L/opt/cell/sdk/usr/lib -lspe2 -lfb_writer_spu -lyuv2rgb_spu -lbilin_scaler_spu"
-
-        if test x$have_spu_libs = xno; then 
-              AC_MSG_WARN([ps3libs missing, please run make ps3libs])
-        fi
-    fi
-    AC_MSG_CHECKING([for PlayStation 3 Cell support])
-    AC_MSG_RESULT([$video_ps3])
-  fi
-}
-
 dnl rcg04172001 Set up the Null video driver.
 CheckDummyVideo()
 {
@@ -2245,7 +2205,6 @@
         CheckX11
         CheckDirectFB
         CheckFusionSound
-        CheckPS3
         CheckOpenGLX11
         CheckInputEvents
         CheckTslib