diff configure.in @ 1820:133d55b02d51

Date: Thu, 11 May 2006 17:09:17 -0400 From: Mike Frysinger Subject: [SDL] [patch] teach configure about uClinux the current configure script doesnt know about the uclinux target so this patch fixes that -mike
author Sam Lantinga <slouken@libsdl.org>
date Thu, 11 May 2006 23:26:45 +0000
parents a7cda692b681
children 77656185d662
line wrap: on
line diff
--- a/configure.in	Thu May 11 21:14:05 2006 +0000
+++ b/configure.in	Thu May 11 23:26:45 2006 +0000
@@ -1608,7 +1608,7 @@
 AC_HELP_STRING([--enable-pthread-sem], [use pthread semaphores [[default=yes]]]),
                   , enable_pthread_sem=yes)
     case "$host" in
-        *-*-linux*)
+        *-*-linux*|*-*-uclinux*)
             pthread_cflags="-D_REENTRANT"
             pthread_lib="-lpthread"
             ;;
@@ -2059,9 +2059,10 @@
             have_timers=yes
         fi
         ;;
-    *-*-linux*|*-*-gnu*|*-*-k*bsd*-gnu|*-*-bsdi*|*-*-freebsd*|*-*-dragonfly*|*-*-netbsd*|*-*-openbsd*|*-*-sysv5*|*-*-solaris*|*-*-hpux*|*-*-irix*|*-*-aix*|*-*-osf*)
+    *-*-linux*|*-*-uclinux*|*-*-gnu*|*-*-k*bsd*-gnu|*-*-bsdi*|*-*-freebsd*|*-*-dragonfly*|*-*-netbsd*|*-*-openbsd*|*-*-sysv5*|*-*-solaris*|*-*-hpux*|*-*-irix*|*-*-aix*|*-*-osf*)
         case "$host" in
             *-*-linux*)         ARCH=linux ;;
+            *-*-uclinux*)       ARCH=linux ;;
             *-*-kfreebsd*-gnu)  ARCH=kfreebsd-gnu ;;
             *-*-knetbsd*-gnu)   ARCH=knetbsd-gnu ;;
             *-*-kopenbsd*-gnu)  ARCH=kopenbsd-gnu ;;