diff configure.in @ 1628:10b4827452a8

Fixed bug #185 The SDL platform header shouldn't dictate the OS target API for other applications. The build system should define the target API for building SDL internally.
author Sam Lantinga <slouken@libsdl.org>
date Thu, 13 Apr 2006 14:14:06 +0000
parents 7e89aa7843c5
children 89e25c25213c
line wrap: on
line diff
--- a/configure.in	Thu Apr 13 14:04:13 2006 +0000
+++ b/configure.in	Thu Apr 13 14:14:06 2006 +0000
@@ -2319,10 +2319,13 @@
         # Next line is broken, and a few files below require Mac OS X (full)
         ARCH=macosx
 
-        # HACK: Reset EXTRA_LDFLAGS; the only thing it contains at this point is 
-        # -lm which is not needed under Mac OS X. But for some reasons it also
-        # tends to contain spurious -L switches, which we don't want to use
-        # here or in sdl-config. Hence we reset it.
+        # Mac OS X builds with both the Carbon and OSX APIs at the moment
+        EXTRA_CFLAGS="-DTARGET_API_MAC_CARBON -DTARGET_API_MAC_OSX"
+
+        # HACK: Reset EXTRA_LDFLAGS; the only thing it contains at this point
+        # is -lm which is not needed under Mac OS X. But for some reasons it
+        # also tends to contain spurious -L switches, which we don't want to
+        # use here or in sdl-config. Hence we reset it.
         EXTRA_LDFLAGS=""
 
         CheckDummyVideo