diff configure.in @ 557:0ce5a68278fd

Updated Atari port for new system headers (thanks Patrice!)
author Sam Lantinga <slouken@libsdl.org>
date Sat, 07 Dec 2002 06:54:47 +0000
parents 0009aadb3d01
children 969fbd4dcd4e
line wrap: on
line diff
--- a/configure.in	Sat Dec 07 06:51:03 2002 +0000
+++ b/configure.in	Sat Dec 07 06:54:47 2002 +0000
@@ -38,8 +38,7 @@
 AC_SUBST(LT_AGE)
 
 dnl Detect the canonical host and target build environment
-AC_CANONICAL_HOST
-AC_CANONICAL_TARGET
+AC_CANONICAL_SYSTEM
 
 dnl Setup for automake
 AM_INIT_AUTOMAKE(SDL, $SDL_VERSION)
@@ -2437,9 +2436,13 @@
         fi
         # Set up files for the timer library
         if test x$enable_timers = xyes; then
-            COPY_ARCH_SRC(src/timer, mint, SDL_systimer.c)
-            COPY_ARCH_SRC(src/timer, mint, SDL_vbltimer.S)
-            COPY_ARCH_SRC(src/timer, mint, SDL_vbltimer_s.h)
+            if test x$enable_threads = xyes -a x$enable_pth = xyes; then
+                COPY_ARCH_SRC(src/timer, linux, SDL_systimer.c)
+            else
+                COPY_ARCH_SRC(src/timer, mint, SDL_systimer.c)
+                COPY_ARCH_SRC(src/timer, mint, SDL_vbltimer.S)
+                COPY_ARCH_SRC(src/timer, mint, SDL_vbltimer_s.h)
+            fi
         fi
         # MiNT does not define "unix"
         CFLAGS="$CFLAGS -Dunix"