diff test/configure.in @ 3087:0b6f51c29267

Date: Wed, 4 Mar 2009 15:38:22 +0200 From: "Mike Gorchak" Subject: Re: About QNX support in SDL 1.3 Here is another batch of patches. 1) Makefile.in - added SDL_opengles.h header as header to install. 2) configure.in - Added special define to detect Common Lite OpenGL ES library in case if Common library is not installed. Added check for clock_gettime in libc (in QNX it is in libc). 3) SDL_config.h.in - Added SDL_VIDEO_RENDER_OPENGL_ES and SDL_VIDEO_OPENGL_ES declarations for configure script autodetection. 4) SDL_opengles.h - Added GL_API definition if it is not defined. Added extension GL_OES_draw_texture because OpenGL ES Renderer uses it without declaration. Added GL_OES_vertex_buffer_object extension, which is supported under QNX OpenGL ES. Added GL_OES_single_precision extension. 5) To the test directory I've added building OpenGL ES test applications through the autotools suite. Was support for iPhone IDE building only.
author Sam Lantinga <slouken@libsdl.org>
date Wed, 04 Mar 2009 15:10:47 +0000
parents 9af6717e676a
children 37f9304df6a9
line wrap: on
line diff
--- a/test/configure.in	Wed Mar 04 09:35:32 2009 +0000
+++ b/test/configure.in	Wed Mar 04 15:10:47 2009 +0000
@@ -49,7 +49,12 @@
         else
             SYS_GL_LIBS="-lOSMesa"
         fi
-		;;
+        ;;
+    *-*-qnx*)
+        EXE=""
+        MATHLIB=""
+        SYS_GL_LIBS="-lGLES_CM"
+        ;;
     *)
         EXE=""
         MATHLIB="-lm"
@@ -99,6 +104,30 @@
 else
     GLLIB=""
 fi
+
+dnl Check for OpenGL ES
+AC_MSG_CHECKING(for OpenGL ES support)
+have_opengles=no
+AC_TRY_COMPILE([
+ #if defined (__QNXNTO__)
+    #include <GLES/gl.h>
+ #elif defined (__IPHONEOS__)
+    #include <OpenGLES/ES1/gl.h>
+ #else
+    #error "No OpenGL ES support"
+ #endif /* __QNXNTO__ */
+],[
+],[
+have_opengles=yes
+])
+AC_MSG_RESULT($have_opengles)
+if test x$have_opengles = xyes; then
+    CFLAGS="$CFLAGS -DHAVE_OPENGLES"
+    GLLIB="$XPATH $SYS_GL_LIBS"
+else
+    GLLIB=""
+fi
+
 AC_SUBST(GLLIB)
 
 dnl Finally create all the generated files