diff configure.in @ 3087:0b6f51c29267

Date: Wed, 4 Mar 2009 15:38:22 +0200 From: "Mike Gorchak" Subject: Re: About QNX support in SDL 1.3 Here is another batch of patches. 1) Makefile.in - added SDL_opengles.h header as header to install. 2) configure.in - Added special define to detect Common Lite OpenGL ES library in case if Common library is not installed. Added check for clock_gettime in libc (in QNX it is in libc). 3) SDL_config.h.in - Added SDL_VIDEO_RENDER_OPENGL_ES and SDL_VIDEO_OPENGL_ES declarations for configure script autodetection. 4) SDL_opengles.h - Added GL_API definition if it is not defined. Added extension GL_OES_draw_texture because OpenGL ES Renderer uses it without declaration. Added GL_OES_vertex_buffer_object extension, which is supported under QNX OpenGL ES. Added GL_OES_single_precision extension. 5) To the test directory I've added building OpenGL ES test applications through the autotools suite. Was support for iPhone IDE building only.
author Sam Lantinga <slouken@libsdl.org>
date Wed, 04 Mar 2009 15:10:47 +0000
parents 4800979de337
children 0d12e8f1de3c
line wrap: on
line diff
--- a/configure.in	Wed Mar 04 09:35:32 2009 +0000
+++ b/configure.in	Wed Mar 04 15:10:47 2009 +0000
@@ -1705,12 +1705,12 @@
         AC_MSG_RESULT($video_opengl)
         if test x$video_opengl = xyes; then
             AC_DEFINE(SDL_VIDEO_OPENGL_ES)
-            AC_DEFINE(SDL_VIDEO_RENDER_OGL_ES)
             EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lGLES_CM"
         else
             AC_MSG_CHECKING(for QNX OpenGL ES (CL) support)
             video_opengl=no
             AC_TRY_COMPILE([
+             #define COMMON_LITE
              #include <GLES/egl.h>
             ],[
             ],[
@@ -1719,7 +1719,6 @@
             AC_MSG_RESULT($video_opengl)
             if test x$video_opengl = xyes; then
                 AC_DEFINE(SDL_VIDEO_OPENGL_ES)
-                AC_DEFINE(SDL_VIDEO_RENDER_OGL_ES)
                 EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lGLES_CL"
             fi
         fi
@@ -2295,6 +2294,12 @@
         if test x$have_clock_gettime = xyes; then
             AC_DEFINE(HAVE_CLOCK_GETTIME)
             EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lrt"
+        else
+            AC_CHECK_LIB(c, clock_gettime, have_clock_gettime=yes)
+            if test x$have_clock_gettime = xyes; then
+               AC_DEFINE(HAVE_CLOCK_GETTIME)
+               EXTRA_LDFLAGS="$EXTRA_LDFLAGS"
+            fi
         fi
     fi
 }