diff src/video/x11/Makefile.am @ 1168:045f186426e1

Dynamically load X11 libraries like we currently do for alsa, esd, etc. This allows you to run an SDL program on a system without Xlib, since it'll just report the x11 target unavailable at runtime.
author Ryan C. Gordon <icculus@icculus.org>
date Sat, 05 Nov 2005 19:53:37 +0000
parents 74212992fb08
children
line wrap: on
line diff
--- a/src/video/x11/Makefile.am	Sat Nov 05 17:41:11 2005 +0000
+++ b/src/video/x11/Makefile.am	Sat Nov 05 19:53:37 2005 +0000
@@ -4,6 +4,9 @@
 noinst_LTLIBRARIES = libvideo_x11.la
 libvideo_x11_la_SOURCES = $(X11_SRCS)
 
+x11_lib = \"@x11_lib@\"
+x11ext_lib = \"@x11ext_lib@\"
+
 # The SDL X11 video driver sources
 X11_SRCS = 			\
 	SDL_x11dga.c		\
@@ -25,4 +28,8 @@
 	SDL_x11wm.c		\
 	SDL_x11wm_c.h		\
 	SDL_x11yuv.c		\
-	SDL_x11yuv_c.h
+	SDL_x11yuv_c.h		\
+	SDL_x11dyn.c		\
+	SDL_x11dyn.h		\
+	SDL_x11sym.h
+