diff test/configure.in @ 3280:00cace2d9080

Merged a cleaned up version of Jiang's code changes from Google Summer of Code 2009
author Sam Lantinga <slouken@libsdl.org>
date Sat, 19 Sep 2009 13:29:40 +0000
parents 37f9304df6a9
children 245a7d79577c
line wrap: on
line diff
--- a/test/configure.in	Sat Sep 19 12:48:52 2009 +0000
+++ b/test/configure.in	Sat Sep 19 13:29:40 2009 +0000
@@ -128,5 +128,23 @@
 
 AC_SUBST(GLLIB)
 
+dnl Check for SDL_ttf
+AC_MSG_CHECKING(for SDL_ttf)
+have_SDL_ttf=no
+AC_TRY_COMPILE([
+ #include "SDL_ttf.h"
+],[
+],[
+have_SDL_ttf=yes
+])
+AC_MSG_RESULT($have_SDL_ttf)
+
+if test x$have_SDL_ttf = xyes; then
+    CFLAGS="$CFLAGS -DHAVE_SDL_TTF"
+    SDL_TTF_LIB="-lSDL_ttf"
+fi
+
+AC_SUBST(SDL_TTF_LIB)
+
 dnl Finally create all the generated files
 AC_OUTPUT([Makefile])