diff setup.py @ 0:febfdc79550b

moved repository to Assembla
author catherine@DellZilla.myhome.westell.com
date Wed, 05 Mar 2008 12:16:19 -0500
parents
children 59288b38ea7b
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Wed Mar 05 12:16:19 2008 -0500
@@ -0,0 +1,46 @@
+#!/usr/bin/python
+from setuptools import setup, find_packages
+
+setup(
+    name="cmd2",
+    version="0.2.1",
+    py_modules = ['cmd2','flagReader'],
+    
+    # metadata for upload to PyPI
+    author = 'Catherine Devlin',
+    author_email = 'catherine.devlin@gmail.com',
+    description = "Extra features for standard library's cmd module",
+    license = 'MIT',
+    keywords = 'command prompt console cmd',
+    url = 'http://www.assembla.com/wiki/show/python-cmd2',
+    
+    long_description = """Enhancements for standard library's cmd module.
+
+Drop-in replacement adds several features for command-prompt tools:
+
+    * Searchable command history (commands: "hi", "li", "run")
+    * Load commands from file, save to file, edit commands in file
+    * Multi-line commands
+    * Case-insensitive commands
+    * Special-character shortcut commands (beyond cmd's "@" and "!")
+    * Settable environment parameters
+    * Parsing commands with flags
+    * Redirection to file with >, >>; input from file with <
+
+Useable without modification anywhere cmd is used; simply import cmd2.Cmd in place of cmd.Cmd.
+
+Usage samples at http://www.assembla.com/wiki/show/python-cmd2/UsageSamples
+""",
+
+    classifiers=[
+        'Development Status :: 4 - Beta',
+        'Environment :: Console',
+        'Operating System :: OS Independent',
+        'Intended Audience :: Developers',
+        'Intended Audience :: System Administrators',
+        'Programming Language :: Python',
+        'License :: OSI Approved :: MIT License',
+        'Topic :: Software Development :: Libraries :: Python Modules',
+    ],
+    )
+