diff setup.py @ 112:e3b8eaadea56

going to collapse down out of overdone package structure
author catherine@Elli.myhome.westell.com
date Sat, 25 Oct 2008 19:28:51 -0400
parents c1e5df33721f
children 7d215852f9a6
line wrap: on
line diff
--- a/setup.py	Fri Oct 24 17:47:56 2008 -0400
+++ b/setup.py	Sat Oct 25 19:28:51 2008 -0400
@@ -3,11 +3,10 @@
 
 setup(
     name="cmd2",
+    version="0.4",
     packages=["cmd2",],
     package_dir={'cmd2': 'cmd2'},
-    package_data={'cmd2': ['example/*.*']},
-    include_package_data=True,
-    version="0.4",
+    package_data={'cmd2': ['example/*.txt', 'example/*.py']},
     
     # metadata for upload to PyPI
     author = 'Catherine Devlin',
@@ -31,7 +30,7 @@
     * > (filename), >> (filename) redirect output to file
     * < (filename) gets input from file
     * bare >, >>, < redirect to/from paste buffer
-    * test apps against sample session transcript (see example.py in source directory)
+    * test apps against sample session transcript (see example/example.py)
 
 Useable without modification anywhere cmd is used; simply import cmd2.Cmd in place of cmd.Cmd.