Mercurial > mm7
comparison lib/swig/swigwin-2.0.11/CCache/debian/patches/08_manpage_hyphens.diff @ 1899:b3009adc0e2f
Adding swig, gitignore, hgignore
author | Nomad |
---|---|
date | Mon, 21 Oct 2013 10:42:27 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
1867:eb580660bbbb | 1899:b3009adc0e2f |
---|---|
1 Index: ccache.1 | |
2 =================================================================== | |
3 --- ccache.1 (révision 7695) | |
4 +++ ccache.1 (copie de travail) | |
5 @@ -49,7 +49,7 @@ | |
6 .IP "\fB-s\fP" | |
7 Print the current statistics summary for the cache\&. The | |
8 statistics are stored spread across the subdirectories of the | |
9 -cache\&. Using "ccache -s" adds up the statistics across all | |
10 +cache\&. Using "ccache \-s" adds up the statistics across all | |
11 subdirectories and prints the totals\&. | |
12 .IP | |
13 .IP "\fB-z\fP" | |
14 @@ -60,7 +60,7 @@ | |
15 .IP | |
16 .IP "\fB-c\fP" | |
17 Clean the cache and re-calculate the cache file count and | |
18 -size totals\&. Normally the -c option should not be necessary as ccache | |
19 +size totals\&. Normally the \-c option should not be necessary as ccache | |
20 keeps the cache below the specified limits at runtime and keeps | |
21 statistics up to date on each compile\&. This option is mostly useful | |
22 if you manually modify the cache contents or believe that the cache | |
23 @@ -100,9 +100,9 @@ | |
24 | |
25 | |
26 cp ccache /usr/local/bin/ | |
27 - ln -s /usr/local/bin/ccache /usr/local/bin/gcc | |
28 - ln -s /usr/local/bin/ccache /usr/local/bin/g++ | |
29 - ln -s /usr/local/bin/ccache /usr/local/bin/cc | |
30 + ln \-s /usr/local/bin/ccache /usr/local/bin/gcc | |
31 + ln \-s /usr/local/bin/ccache /usr/local/bin/g++ | |
32 + ln \-s /usr/local/bin/ccache /usr/local/bin/cc | |
33 | |
34 .fi | |
35 | |
36 @@ -118,7 +118,7 @@ | |
37 .PP | |
38 When run as a compiler front end ccache usually just takes the same | |
39 command line options as the compiler you are using\&. The only exception | |
40 -to this is the option \&'--ccache-skip\&'\&. That option can be used to tell | |
41 +to this is the option \&'\-\-ccache-skip\&'\&. That option can be used to tell | |
42 ccache that the next option is definitely not a input filename, and | |
43 should be passed along to the compiler as-is\&. | |
44 .PP | |
45 @@ -128,7 +128,7 @@ | |
46 of the resulting object file (among other things)\&. The heuristic | |
47 ccache uses in this parse is that any string on the command line that | |
48 exists as a file is treated as an input file name (usually a C | |
49 -file)\&. By using --ccache-skip you can force an option to not be | |
50 +file)\&. By using \-\-ccache-skip you can force an option to not be | |
51 treated as an input file name and instead be passed along to the | |
52 compiler as a command line option\&. | |
53 .PP | |
54 @@ -238,7 +238,7 @@ | |
55 .IP "\fBCCACHE_UNIFY\fP" | |
56 If you set the environment variable CCACHE_UNIFY | |
57 then ccache will use the C/C++ unifier when hashing the pre-processor | |
58 -output if -g is not used in the compile\&. The unifier is slower than a | |
59 +output if \-g is not used in the compile\&. The unifier is slower than a | |
60 normal hash, so setting this environment variable loses a little bit | |
61 of speed, but it means that ccache can take advantage of not | |
62 recompiling when the changes to the source code consist of | |
63 @@ -262,7 +262,7 @@ | |
64 .PP | |
65 By default ccache has a one gigabyte limit on the cache size and no | |
66 maximum number of files\&. You can set a different limit using the | |
67 -"ccache -M" and "ccache -F" options, which set the size and number of | |
68 +"ccache \-M" and "ccache \-F" options, which set the size and number of | |
69 files limits\&. | |
70 .PP | |
71 When these limits are reached ccache will reduce the cache to 20% | |
72 @@ -276,7 +276,7 @@ | |
73 that it is the same code by forming a hash of: | |
74 .PP | |
75 .IP o | |
76 -the pre-processor output from running the compiler with -E | |
77 +the pre-processor output from running the compiler with \-E | |
78 .IP o | |
79 the command line options | |
80 .IP o | |
81 @@ -331,7 +331,7 @@ | |
82 .IP o | |
83 Make sure that the setgid bit is set on all directories in the | |
84 cache\&. This tells the filesystem to inherit group ownership for new | |
85 -directories\&. The command "chmod g+s `find $CCACHE_DIR -type d`" might | |
86 +directories\&. The command "chmod g+s `find $CCACHE_DIR \-type d`" might | |
87 be useful for this\&. | |
88 .PP | |
89 .SH "HISTORY" |