diff CMakeLists.txt @ 13:54aa96ae8912

Added LinkedList class to project. ALmixer now saves ALmixer_Data instances in a private linked list so when Quit is called, this memory can be cleaned up. This is meant to deal with two problems. First, SDL_sound does something similar which means since I wrap SDL_sound structures, I may be left with dangling pointers if. Second is the obvious auto-cleanup when quiting which is convenient for resetting.
author Eric Wing <ewing . public |-at-| gmail . com>
date Sat, 06 Nov 2010 00:37:29 -0700
parents a71ed111a627
children
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Nov 05 20:59:13 2010 -0700
+++ b/CMakeLists.txt	Sat Nov 06 00:37:29 2010 -0700
@@ -62,6 +62,8 @@
 	${ALmixer_SOURCE_DIR}/ALmixer.c
 	${ALmixer_SOURCE_DIR}/CircularQueue.c
 	${ALmixer_SOURCE_DIR}/CircularQueue.h
+	${ALmixer_SOURCE_DIR}/LinkedList.c
+	${ALmixer_SOURCE_DIR}/LinkedList.h
 )
 
 SET(PUBLIC_HEADERS