diff setup.py @ 348:c652478be4fd

migrated \dt to gerald
author catherine@cordelia
date Fri, 24 Apr 2009 15:09:29 -0400
parents aa16fe026f01
children
line wrap: on
line diff
--- a/setup.py	Thu Apr 23 19:10:05 2009 -0400
+++ b/setup.py	Fri Apr 24 15:09:29 2009 -0400
@@ -17,8 +17,11 @@
       url="http://packages.python.org/sqlpython",
       packages=find_packages(),
       include_package_data=True,    
-      install_requires=['pyparsing','cmd2>=0.5.2','cx_Oracle','genshi>=0.5','sqlalchemy',],
-      keywords = 'client oracle database',
+      install_requires=['pyparsing','cmd2>=0.5.2','genshi>=0.5','sqlalchemy','gerald'],
+      extras_require = {'oracle': ['cx_Oracle'],
+                        'mysql': ['MySQL-python'],
+                        'postgres': ['psycopg2']},
+      keywords = 'client oracle database rdbms sql',
       license = 'MIT',
       platforms = ['any'],
       entry_points = """