diff setup.py @ 477:920a45f244e8

setuptools optional
author catherine@dellzilla
date Fri, 12 Mar 2010 19:42:11 -0500
parents d0164c122938
children 8cf08822207b
line wrap: on
line diff
--- a/setup.py	Thu Mar 11 16:11:42 2010 -0500
+++ b/setup.py	Fri Mar 12 19:42:11 2010 -0500
@@ -1,5 +1,10 @@
-from setuptools import setup, find_packages
-
+try:
+    from setuptools import setup, find_packages
+except ImportError:
+    from distutils.core import setup
+    def find_packages():
+        return ['sqlpython']
+    
 classifiers = """Development Status :: 4 - Beta
 Intended Audience :: Information Technology
 License :: OSI Approved :: MIT License