diff setup.py @ 188:4a639619814a

sending changes to dellzilla
author catherine@dellzilla
date Mon, 17 Nov 2008 13:14:29 -0500
parents 4c59f4a8b680
children 3ca2271847e2
line wrap: on
line diff
--- a/setup.py	Fri Aug 29 13:38:31 2008 -0400
+++ b/setup.py	Mon Nov 17 13:14:29 2008 -0500
@@ -9,21 +9,21 @@
 Operating System :: OS Independent""".splitlines()
 
 setup(name="sqlpython",
-      version="1.4.8",
+      version="1.5.0",
       description="Command-line interface to Oracle",
       long_description="Customizable alternative to Oracle's SQL*PLUS command-line interface",
       author="Luca Canali",
       author_email="luca.canali@cern.ch",
       url="https://twiki.cern.ch/twiki/bin/view/PSSGroup/SqlPython",
       packages=find_packages(),
-      py_modules = ['mysqlpy','completion','sqlpyPlus','sqlpython','pexpecter'],    
       include_package_data=True,    
-      install_requires=['pyparsing','cmd2>=0.3.5','cx_Oracle'],
+      install_requires=['pyparsing','cmd2>=0.4.3','cx_Oracle','genshi>=0.5'],
       keywords = 'client oracle database',
       license = 'MIT',
       platforms = ['any'],
       entry_points = """
                    [console_scripts]
-                   sqlpython = mysqlpy:run"""      
+                   sqlpython = sqlpython.mysqlpy:run
+                   editplot_sqlpython = sqlpython.editplot.bash"""      
      )