diff setup.py @ 415:3a2db0db302f

must synch
author catherine@bothari
date Fri, 30 Oct 2009 19:45:23 -0400
parents 9c724e555c91
children fc3e99c9e3e5
line wrap: on
line diff
--- a/setup.py	Fri Oct 16 18:11:08 2009 -0400
+++ b/setup.py	Fri Oct 30 19:45:23 2009 -0400
@@ -17,8 +17,12 @@
       url="http://packages.python.org/sqlpython",
       packages=find_packages(),
       include_package_data=True,    
-      install_requires=['pyparsing','cmd2>=0.5.6','cx_Oracle>=5.0.2',
+      install_requires=['pyparsing','cmd2>=0.5.6',
                         'genshi>=0.5','sqlalchemy'],
+      extras_require = {
+        'oracle':  ['cx_Oracle>=5.0.2'],
+        'postgres': ['psycopg2'],
+        },
       keywords = 'client oracle database',
       license = 'MIT',
       platforms = ['any'],