diff src/main/Makefile.am @ 754:623b453a3219

Fixed "dist" make target for newer versions of automake
author Sam Lantinga <slouken@libsdl.org>
date Sun, 14 Dec 2003 06:25:53 +0000
parents db0cc6034336
children 2cbb8eaa2c92
line wrap: on
line diff
--- a/src/main/Makefile.am	Wed Dec 10 12:35:56 2003 +0000
+++ b/src/main/Makefile.am	Sun Dec 14 06:25:53 2003 +0000
@@ -6,44 +6,40 @@
 
 ARCH_SUBDIRS = $(srcdir)/beos \
                $(srcdir)/epoc \
-               $(srcdir)/linux \
+               $(srcdir)/dummy \
                $(srcdir)/macos \
                $(srcdir)/macosx \
+               $(srcdir)/qtopia \
                $(srcdir)/win32
 
 # Build a separate library containing the main() entry point.
 lib_LIBRARIES = libSDLmain.a
 
+if TARGET_WIN32
+MAINLIB_ARCH_SRCS = win32/SDL_win32_main.c
+else
 if TARGET_MACOSX
-MAINLIB_ARCH_SRCS = SDLMain.m SDLMain.h
+MAINLIB_ARCH_SRCS = macosx/SDLMain.m macosx/SDLMain.h
 else
 if TARGET_QTOPIA
-MAINLIB_ARCH_SRCS = SDL_Qtopia_main.cc
+MAINLIB_ARCH_SRCS = qtopia/SDL_qtopia_main.cc
 else
-MAINLIB_ARCH_SRCS = SDL_main.c
-endif
-endif
+MAINLIB_ARCH_SRCS = dummy/SDL_dummy_main.c
+endif !TARGET_QTOPIA
+endif !TARGET_MACOSX
+endif !TARGET_WIN32
 libSDLmain_a_SOURCES = $(MAINLIB_ARCH_SRCS)
 
 # Build an internal library of any special app setup functions
 noinst_LTLIBRARIES = libarch.la
 
 if TARGET_BEOS
-ARCH_SRCS = SDL_BeApp.cc SDL_BeApp.h
+ARCH_SRCS = beos/SDL_BeApp.cc beos/SDL_BeApp.h
 else
-ARCH_SRCS = 
+ARCH_SRCS = arch.c
 endif
 
-# Include the architecture-independent sources
-COMMON_SRCS = dummy.c
-
-libarch_la_SOURCES = $(COMMON_SRCS) $(ARCH_SRCS)
-
-## Let automake know that it shouldn't distribute linked sources
-BUILT_SOURCES = $(MAINLIB_ARCH_SRCS) $(ARCH_SRCS)
-
-## Let automake know that it should remove these for distribution
-DISTCLEANFILES = $(MAINLIB_ARCH_SRCS) $(ARCH_SRCS)
+libarch_la_SOURCES = $(ARCH_SRCS)
 
 # The architecture specific directories need to be copied into place
 # when building a distribution.