diff setup.py @ 0:ff263bdd455e

initial checkin
author Victor Ng <victor@monkeybean.ca>
date Thu, 28 Aug 2008 09:44:43 -0400
parents
children 1a416359a617
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Thu Aug 28 09:44:43 2008 -0400
@@ -0,0 +1,24 @@
+from setuptools import setup, find_packages
+
+setup(
+    name='NoseDjango',
+    version='0.5',
+    author='Victor Ng',
+    author_email = 'victor.ng@monkeybeanonline.com',
+    description = 'nose plugin for easy testing of django projects ' \
+        'and apps. Sets up a test database (or schema) and installs apps ' \
+        'from test settings file before tests are run, and tears the test ' \
+        'database (or schema) down after all tests are run.',
+    install_requires='nose>=0.10',
+    url = "http://poli-cms.googlecode.com/svn/nose-django/",
+    license = 'GNU LGPL',
+    packages = find_packages(exclude=['tests']),
+    zip_safe = False,
+    include_package_data = True,
+    entry_points = {
+        'nose.plugins': [
+            'django = nosedjango.nosedjango:NoseDjango',
+            ]
+        }
+    )
+