diff data_generation/transformations/pycaptcha/setup.py @ 167:1f5937e9e530

More moves - transformations into data_generation, added "deep" folder
author Dumitru Erhan <dumitru.erhan@gmail.com>
date Fri, 26 Feb 2010 14:15:38 -0500
parents pycaptcha/setup.py@4775b4195b4b
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/data_generation/transformations/pycaptcha/setup.py	Fri Feb 26 14:15:38 2010 -0500
@@ -0,0 +1,28 @@
+#!/usr/bin/env python
+from distutils.core import setup
+from setup.my_install_data import *
+
+setup (name = "PyCAPTCHA",
+       version = "0.4",
+       description = "A Python framework for CAPTCHA tests",
+       maintainer = "Micah Dowty",
+       maintainer_email = "micah@navi.cx",
+       license = "MIT",
+       packages = [
+           'Captcha',
+           'Captcha.Visual',
+       ],
+       cmdclass = {
+           'install_data': my_install_data,
+       },
+       data_files = [Data_Files(
+           preserve_path = 1,
+           base_dir      = 'install_lib',
+           copy_to       = 'Captcha/data',
+           strip_dirs    = 2,
+           template      = [
+               'graft Captcha/data',
+           ],
+       )],
+       )
+