diff ext/guichan-0.8.1/src/Makefile.am @ 0:4a0efb7baf70

* Datasets becomes the new trunk and retires after that :-)
author mvbarracuda@33b003aa-7bff-0310-803a-e67f0ece8222
date Sun, 29 Jun 2008 18:44:17 +0000
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/ext/guichan-0.8.1/src/Makefile.am	Sun Jun 29 18:44:17 2008 +0000
@@ -0,0 +1,39 @@
+SUBDIRS = widgets @GUICHAN_EXTRADIRS@ hge openlayer contrib
+
+INCLUDES = -I$(top_srcdir)/include
+
+lib_LTLIBRARIES = libguichan.la
+
+libguichan_la_LIBADD = widgets/libguichan_widgets.la
+
+libguichan_la_LDFLAGS = -no-undefined -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) 
+
+libguichan_la_DEPENDENCIES = \
+	widgets/libguichan_widgets.la
+
+# The Gui-chan library sources
+libguichan_la_SOURCES = 	\
+	actionevent.cpp		\
+	basiccontainer.cpp	\
+	cliprectangle.cpp	\
+	color.cpp		\
+	defaultfont.cpp		\
+	event.cpp		\
+	exception.cpp		\
+	focushandler.cpp	\
+	font.cpp		\
+	genericinput.cpp	\
+	graphics.cpp		\
+	gui.cpp			\
+	guichan.cpp		\
+	image.cpp		\
+	imagefont.cpp		\
+	inputevent.cpp		\
+	key.cpp			\
+	keyevent.cpp		\
+	keyinput.cpp		\
+	mouseevent.cpp		\
+	mouseinput.cpp		\
+	rectangle.cpp		\
+	selectionevent.cpp	\
+	widget.cpp