diff configure.in @ 495:d0d381a6f2bb stable-1.0

Look for modplug headers in both include path and include path + "libmodplug". (thanks to Tyler for this one).
author Ryan C. Gordon <icculus@icculus.org>
date Wed, 12 Oct 2005 22:13:34 +0000
parents 636796aed4e2
children b4e9fb8ef9f6
line wrap: on
line diff
--- a/configure.in	Sat Oct 01 15:35:53 2005 +0000
+++ b/configure.in	Wed Oct 12 22:13:34 2005 +0000
@@ -214,7 +214,16 @@
 [  --enable-modplug           enable MOD decoding via modplug [default=yes]],
               , enable_modplug=yes)
 if test x$enable_modplug = xyes; then
+  have_modplug_hdr=no
   AC_CHECK_HEADER(modplug.h, have_modplug_hdr=yes)
+  if test x$have_modplug_hdr = xno; then
+    AC_CHECK_HEADER(libmodplug/modplug.h, have_modplug_hdr=yes)
+    if test x$have_modplug_hdr = xyes; then
+      have_modplug_hdr=yes
+      AC_DEFINE(SOUND_MODPLUG_IN_OWN_PATH)
+    fi
+  fi
+
   AC_CHECK_LIB(modplug, ModPlug_Load, have_modplug_lib=yes)
   if test x$have_modplug_hdr = xyes -a x$have_modplug_lib = xyes; then
     LIBS="$LIBS -lmodplug"