diff configure.in @ 562:7e08477b0fc1

MP3 decoder upgrade work. Ripped out SMPEG and mpglib support, replaced it with "mpg123.c" and libmpg123. libmpg123 is a much better version of mpglib, so it should solve all the problems about MP3's not seeking, or most modern MP3's not playing at all, etc. Since you no longer have to make a tradeoff with SMPEG for features, and SMPEG is basically rotting, I removed it from the project. There is still work to be done with libmpg123...there are MMX, 3DNow, SSE, Altivec, etc decoders which we don't have enabled at the moment, and the build system could use some work to make this compile more cleanly, etc. Still: huge win.
author Ryan C. Gordon <icculus@icculus.org>
date Fri, 30 Jan 2009 02:44:47 -0500
parents f2985e08589c
children cddbe182ae5e
line wrap: on
line diff
--- a/configure.in	Fri Jan 30 01:54:03 2009 -0500
+++ b/configure.in	Fri Jan 30 02:44:47 2009 -0500
@@ -54,6 +54,7 @@
 AC_PROG_CC
 AC_PROG_INSTALL
 AC_PROG_LN_S
+AM_PROG_AS
 AM_PROG_LIBTOOL
 
 
@@ -172,28 +173,14 @@
   AC_DEFINE(SOUND_SUPPORTS_MIDI, 1, [Define if MIDI support is desired.])
 fi
 
-dnl Check for SMPEG
-AC_ARG_ENABLE(smpeg,
-[  --enable-smpeg             enable MP3 decoding via smpeg [default=yes]],
-              , enable_smpeg=yes)
-if test x$enable_smpeg = xyes; then
-  AC_CHECK_HEADER(smpeg.h, have_smpeg_hdr=yes)
-  AC_CHECK_LIB(smpeg, SMPEG_new, have_smpeg_lib=yes)
-  if test x$have_smpeg_hdr = xyes -a x$have_smpeg_lib = xyes; then
-    LIBS="$LIBS -lsmpeg"
-    AC_DEFINE(SOUND_SUPPORTS_SMPEG, 1, [Define if SMPEG support is desired.])
-  fi
+dnl Check for the MP3 decoder...
+AC_ARG_ENABLE(mpg123,
+[  --enable-mpg123            enable MP3 decoding [default=yes]],
+              , enable_mpg123=yes)
+if test x$enable_mpg123 = xyes; then
+  AC_DEFINE(SOUND_SUPPORTS_MPG123, 1, [Define if MPG123 support is desired.])
 fi
 
-dnl Check for the MIDI decoder...
-AC_ARG_ENABLE(mpglib,
-[  --enable-mpglib            enable MP3 decoding internally [default=yes]],
-              , enable_mpglib=yes)
-if test x$enable_mpglib = xyes; then
-  AC_DEFINE(SOUND_SUPPORTS_MPGLIB, 1, [Define if MPGLIB support is desired.])
-fi
-
-
 dnl Check for libmikmod
 AC_ARG_ENABLE(mikmod,
 [  --enable-mikmod            enable MOD decoding via mikmod [default=yes]],
@@ -341,13 +328,13 @@
 
 dnl Add Makefile conditionals
 AM_CONDITIONAL(USE_TIMIDITY, test x$enable_midi = xyes)
-AM_CONDITIONAL(USE_MPGLIB, test x$enable_mpglib = xyes)
+AM_CONDITIONAL(USE_LIBMPG123, test x$enable_mpg123 = xyes)
 AM_CONDITIONAL(USE_PHYSICSFS, test x$enable_physfs = xyes)
 
 AC_OUTPUT([
 Makefile
 decoders/Makefile
 decoders/timidity/Makefile
-decoders/mpglib/Makefile
+decoders/libmpg123/Makefile
 playsound/Makefile
 ])