diff Makefile.am @ 340:5a72981b8cba

Added optional, experimental audio conversion routines by Frank Ranostaj.
author Ryan C. Gordon <icculus@icculus.org>
date Mon, 20 May 2002 16:21:58 +0000
parents 31cc49d7d0ce
children 5dbf2f9cde00
line wrap: on
line diff
--- a/Makefile.am	Mon May 20 16:21:20 2002 +0000
+++ b/Makefile.am	Mon May 20 16:21:58 2002 +0000
@@ -6,12 +6,18 @@
 libSDL_soundinclude_HEADERS =	\
 	SDL_sound.h
 
+if USE_ALTCVT
+CVT_SOURCE = alt_audio_convert.c
+else
+CVT_SOURCE = audio_convert.c
+endif
+
 libSDL_sound_la_SOURCES =	\
 	SDL_sound.c	\
 	SDL_sound_internal.h	\
+    $(CVT_SOURCE)   \
 	extra_rwops.c	\
-	extra_rwops.h	\
-	audio_convert.c
+	extra_rwops.h
 
 if USE_TIMIDITY
 TIMIDITY_LIB = decoders/timidity/libtimidity.la