diff Makefile.am @ 201:56bc776f0563

Midi support.
author Ryan C. Gordon <icculus@icculus.org>
date Fri, 04 Jan 2002 06:51:12 +0000
parents 47cc2de2ae36
children fe5251b5624c
line wrap: on
line diff
--- a/Makefile.am	Fri Jan 04 06:50:37 2002 +0000
+++ b/Makefile.am	Fri Jan 04 06:51:12 2002 +0000
@@ -13,14 +13,20 @@
 	extra_rwops.h	\
 	audio_convert.c
 
+if USE_TIMIDITY
+TIMIDITY_LIB = decoders/timidity/libtimidity.la
+else
+TIMIDITY_LIB =
+endif
+
 libSDL_sound_la_LDFLAGS = 		\
 	-release $(LT_RELEASE)	\
 	-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-libSDL_sound_la_LIBADD = decoders/libdecoders.la
-
+libSDL_sound_la_LIBADD =	\
+	decoders/libdecoders.la	\
+	$(TIMIDITY_LIB)
 
 EXTRA_DIST =	\
 	CREDITS \
 	COPYING \
 	CHANGELOG
-