diff playsound/Makefile.am @ 288:259daddc2d6b

PhysicsFS support tied into build system.
author Ryan C. Gordon <icculus@icculus.org>
date Sat, 16 Mar 2002 08:48:00 +0000
parents 7e74765ad928
children c2a25d2b5784
line wrap: on
line diff
--- a/playsound/Makefile.am	Sat Mar 16 08:47:29 2002 +0000
+++ b/playsound/Makefile.am	Sat Mar 16 08:48:00 2002 +0000
@@ -2,4 +2,17 @@
 
 INCLUDES = -I$(top_srcdir)
 
-playsound_LDADD = ../libSDL_sound.la
+if USE_PHYSICSFS
+PHYSFS_CFLG = -DSUPPORT_PHYSFS=1
+PHYSFS_SRCS = physfsrwops.c
+PHYSFS_LIBS = -lphysfs
+else
+PHYSFS_CFLG =
+PHYSFS_SRCS =
+PHYSFS_LIBS =
+endif
+
+playsound_CFLAGS = $(PHYSFS_CFLG)
+playsound_LDADD = ../libSDL_sound.la $(PHYSFS_LIBS)
+playsound_SOURCES = playsound.c $(PHYSFS_SRCS)
+