view debian/madbuilder.postinst @ 1315:fcff6978f9bf

User can switch components. - component_manager will change domview._scenes_node and domview._layers_parent for switching component and timeline. - domview relys on domview._scenes_node and domview._layers_parent to find scene nodes and layers.
author Thinker K.F. Li <thinker@codemud.net>
date Sat, 22 Jan 2011 14:23:42 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi