view debian/madbuilder.postinst @ 1476:eddec4543761

Install layers for FSM_window. - Create background, fsm_layer and control_layer for FSM_window. - All states and transitions are placed in fsm_layer. - All controls (resize, control points, ...) are placed in control_layer.
author Thinker K.F. Li <thinker@codemud.net>
date Sun, 24 Apr 2011 18:52:55 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi