view debian/madbuilder.postinst @ 494:ebc431f2af70 Android_Skia

Fix issue of replace realloc and malloc. Since autoconf always say malloc and realloc are not defined when it is running for cross-compiling. We use a predefined configure cache file to hard set for the realloc and malloc.
author Thinker K.F. Li <thinker@branda.to>
date Thu, 26 Nov 2009 15:03:00 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi