Mercurial > MadButterfly
view debian/rules @ 1214:e55499f7505a
Fix the issues with multiple framelines
- For multiple framelines, user move mouse from one frameline to
another, the frame is not showed correctly.
- Old implementation always draw normal frame on the frameline
where mouse just leaving.
- It is fixed by detecting leave-notify event and removing hover
mark.
- When user active a frame on a frameline that is not what old active
frame is at, the old active frame is not deactivated.
- It is fixed by calling frameline.deactive() of a frameline when a
frame is activated on another frameline.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Wed, 05 Jan 2011 17:56:14 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/usr/bin/make -f MOZ_EXTENSION_PKG := madbuilder MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi . include /usr/share/cdbs/1/rules/debhelper.mk include /usr/share/cdbs/1/class/autotools.mk include /usr/share/mozilla-devscripts/xpi.mk TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb install/madbuilder:: install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \ ${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin mkdir -p ${TEMPLATE_PATH} cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}