view debian/madbuilder.postinst @ 1524:d46ba9e7f837

Update action list with timeline names of current component.
author Thinker K.F. Li <thinker@codemud.net>
date Mon, 22 Aug 2011 14:53:55 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi