view debian/madbuilder.postinst @ 1338:d0e6f350b3fd

Clear change log to prevent from undo/redo. - commit the transaction after changing DOM-tree. - prevent SPObject document from adding changes into the log of undo/redo. - If a changes is not in the log of undo/redo, it would not be redo.
author Thinker K.F. Li <thinker@codemud.net>
date Sat, 05 Feb 2011 18:08:57 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi