view debian/madbuilder.postinst @ 523:c3fe9e4bdec1 Android_Skia

Fix a bug of a non-initialized variable. pos_cnt is not initialized before used. It causes - tank shows nothing at begining. - dynamic being segmentation fault for any X event at first few seconds.
author Thinker K.F. Li <thinker@branda.to>
date Tue, 22 Dec 2009 11:04:52 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi