view debian/madbuilder.postinst @ 436:c02d2aa2c45e

Fig the bug that sh_stext can not show text with right color. It is caused by sh_stext draw text directly into surface. It should create a path instead of draw directly, since rdman would draw the path with right color, stroke, and opacity.
author Thinker K.F. Li <thinker@branda.to>
date Thu, 30 Jul 2009 12:11:27 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi