Mercurial > MadButterfly
view debian/madbuilder.postinst @ 1095:bced6fe39856
Fix position (collision) detection for OpenVG.
We still have no way to check if a point is in the fill area of a
shape for OpenVG. So, we only use current area (rectangle) of a shape
to determine it. So, mbe_in_fill() of OpenVG always return true.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Sat, 04 Dec 2010 13:48:43 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/bin/bash HEADER="#MadBuilder Configuration#" FOOTER="#End of MadBuilder Configuration#" RC=/etc/mozpluggerrc CONTAIN=`grep "$HEADER" $RC` if [ -z "$CONTAIN" ] then cat <<EOF >> $RC $HEADER application/x-mbsvg:mbsvg: MadButterfly SVG swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file" application/x-h:h: MadButterfly SVG h program swallow(gedit) : gedit "\$file" $FOOTER EOF echo Configuration installed to $RC fi